Chyba “Object reference not set to an instance of an object” při deployi Azure Cloud Service

Tomáš Herceg       20. 4. 2015       Visual Studio, Azure       4359 zobrazení

Dnes jsem potřeboval nasadit jednu starší Cloud Service a při deploymentu se objevila následující chyba.

image

Hledání na Googlu směřovalo hlavně k prověření faktu, jestli jsou nastavené správné certifikáty v portálu a v projektu, což jsem několikrát kontroloval, dokonce jsem zkusil vygenerovat nové, ale nepomohlo to.

Nakonec jsem zjistil, že při upgradu z Azure SDK 2.4 na 2.5 Visual Studio někdy nesprávně zmigruje soubor diagnostics.wadcfgx. Řešením je příslušné soubory smazat, kliknout na každou roli pravým tlačítkem a vybrat Add Diagnostics Configuration, čímž se vytvoří nová defaultní a ve správném formátu.

image

 

hodnocení článku

0       Hodnotit mohou jen registrované uživatelé.

 

Nový příspěvek

 

Příspěvky zaslané pod tento článek se neobjeví hned, ale až po schválení administrátorem.

                       
Nadpis:
Antispam: Komu se občas házejí perly?
Příspěvek bude publikován pod identitou   anonym.

Nyní zakládáte pod článkem nové diskusní vlákno.
Pokud chcete reagovat na jiný příspěvek, klikněte na tlačítko "Odpovědět" u některého diskusního příspěvku.

Nyní odpovídáte na příspěvek pod článkem. Nebo chcete raději založit nové vlákno?

 

  • Administrátoři si vyhrazují právo komentáře upravovat či mazat bez udání důvodu.
    Mazány budou zejména komentáře obsahující vulgarity nebo porušující pravidla publikování.
  • Pokud nejste zaregistrováni, Vaše IP adresa bude zveřejněna. Pokud s tímto nesouhlasíte, příspěvek neodesílejte.

Příspěvky zaslané pod tento článek se neobjeví hned, ale až po schválení administrátorem.

přihlásit pomocí externího účtu

přihlásit pomocí jména a hesla

Uživatel:  
Heslo:  

zapomenuté heslo

 

založit nový uživatelský účet

zaregistrujte se

 
zavřít

Nahlásit spam

Opravdu chcete tento příspěvek nahlásit pro porušování pravidel fóra?

Nahlásit Zrušit

Chyba

zavřít

feedback